Performance

The Life and Times of the Old Fogies NS2 server.

Performance

Postby Florp Incarnate » Fri Feb 01, 2013 10:20 am

Unfortunately the latest builds have caused a nosedive in server performance.

http://forums.unknownworlds.com/discussion/127664/not-liking-performance-in-238

NFO is looking into it but there is not a lot they can do. Other providers are also having this difficulty (CEO of NS2Servers comments on this in the thread above).
User avatar
Florp Incarnate
Resident Non-Thieving Pie Overlord
Resident Non-Thieving Pie Overlord
 
Posts: 5704
Joined: Sat Aug 16, 2003 10:06 pm
Location: Commercial Drive, East Van

Re: Performance

Postby Florp Incarnate » Fri Feb 01, 2013 10:50 am

NFO support ticket:

*******************
Thu, Jan 31 2013 11:11pm
Hello NFO Support,

We noticed considerable slowdowns during our prime time hours this evening PST which heavily impacted our ability to play. I took a screen shot of the NS2 web admin performance counter.

http://i.imgur.com/0kg8EJA.jpg

I would appreciate it if you would investigate.

*******************
Thu, Jan 31 2013 11:14pm - answered by Jordan
Hi,

I'd be happy to look in to your server and see what's going on. I've been tracking NS2 closely and your not the only ones seeing issues:

http://forums.unknownworlds.com/discuss ... nce-in-238

238/239 seems to have some issues with performance that I and others have noticed.

Looking at your machine specifically I see everything being in good condition. CPU usage is currently at 29% for the entire box and there is a little over 21GB of ram available. Other then the maintenance event that was posted a few days ago I am not seeing anything related there.

When do you notice the issues such as tickrate drop? How many players, any specific map..etc?

*******************
Fri, Feb 1 2013 10:49am
Between 8pm and 12am PST.

I am going to keep an eye on it and try to get back to you with the information that you requested.
User avatar
Florp Incarnate
Resident Non-Thieving Pie Overlord
Resident Non-Thieving Pie Overlord
 
Posts: 5704
Joined: Sat Aug 16, 2003 10:06 pm
Location: Commercial Drive, East Van

Re: Performance

Postby Florp Incarnate » Fri Feb 01, 2013 10:51 am

Fogies:
If you are playing, please open web admin to the performance tab and keep it open while in-game. If there are lag spikes, please write down:

What map?
How many players?
What approximate time of day?

I will take that back to NFO support.
User avatar
Florp Incarnate
Resident Non-Thieving Pie Overlord
Resident Non-Thieving Pie Overlord
 
Posts: 5704
Joined: Sat Aug 16, 2003 10:06 pm
Location: Commercial Drive, East Van

Re: Performance

Postby BigDXLT » Fri Feb 01, 2013 10:08 pm

Wasn't in game, but looking at perf tab at about 9:55ish tickrate took a nose dive. Hit about 13 before slowly crawling up to 25ish. Then it nosedived again in the time it took to write this post. (Which is a space of 10 minutes or so) and then shot back up when the round apparently ended. I asked faust about it, he didn't see much problem in game.
Funner then chuckin' rocks at a sign!
User avatar
BigDXLT
the First Motorized Sasquatch
the First Motorized Sasquatch
 
Posts: 4658
Joined: Sun Mar 30, 2003 3:29 am
Location: Fraser Lake, BC

Re: Performance

Postby Florp Incarnate » Sat Feb 02, 2013 10:31 am

NFO asked me to take DAK offline for a day to see if it makes any performance improvements. Sorry about this. I will re-enable tomorrow.
User avatar
Florp Incarnate
Resident Non-Thieving Pie Overlord
Resident Non-Thieving Pie Overlord
 
Posts: 5704
Joined: Sat Aug 16, 2003 10:06 pm
Location: Commercial Drive, East Van

Re: Performance

Postby Faust » Sat Feb 02, 2013 7:40 pm

Performance is pretty good tonight:

http://i.imgur.com/tuducU5.png

Could DAK be the cause of poor server performance?
User avatar
Faust
Fogey
Fogey
 
Posts: 1780
Joined: Thu Jun 03, 2004 11:17 am
Location: BC, Canada

Re: Performance

Postby Wayward » Wed Mar 13, 2013 11:28 pm

Been getting intermittent lag spikes on occasion across the server. When it happens usually someone confirms that it wasn't just individual. I may simply be paying more attention now but it seems to have been happening with slightly more frequency. Zippo, SockMonkee, TomTom and BigD should be able to corroborate this.
User avatar
Wayward
Young Insolent Whipper Snapper
 
Posts: 6
Joined: Sun Feb 10, 2013 10:52 am
Location: London, Ontario Canada

Re: Performance

Postby Faust » Wed Mar 13, 2013 11:51 pm

Wayward wrote:Been getting intermittent lag spikes on occasion across the server. When it happens usually someone confirms that it wasn't just individual. I may simply be paying more attention now but it seems to have been happening with slightly more frequency. Zippo, SockMonkee, TomTom and BigD should be able to corroborate this.


When did you feel things started happening in higher frequency? In the past couple months or so, our host, NFO has had semi-frequent ddos issues. In fact they had to tweak their firewall settings in order to fix a nasty bug on ns2 servers that they host (the tighter firewall restrictions stemmed from ddos issues). If I can get some more info, like when the lag spikes happen, when they started occurring in higher frequency, I'll pass on the inquiry to NFO.
User avatar
Faust
Fogey
Fogey
 
Posts: 1780
Joined: Thu Jun 03, 2004 11:17 am
Location: BC, Canada

Re: Performance

Postby Wayward » Thu Mar 14, 2013 1:41 am

The further you go back the less certain I am of when it was happening. I know for sure I've noticed it the last two nights and over the weekend. I've only become aware of it when someone mentioned that they had experienced a lag spike and asked if anyone else had. I'd generally assumed up to that point that it was a hiccup on my end. Concretely I can say it's been happening over the past week. Just certain games would have a slew of them, which wouldn't be that distracting save the fact that certain people in combat really feel the annoyance.
User avatar
Wayward
Young Insolent Whipper Snapper
 
Posts: 6
Joined: Sun Feb 10, 2013 10:52 am
Location: London, Ontario Canada

Re: Performance

Postby Florp Incarnate » Fri Mar 15, 2013 8:20 am

It changes every patch. NFO has absolved themselves and is blaming UWE; I am inclined to agree with them. We are on a beefy physical server.
User avatar
Florp Incarnate
Resident Non-Thieving Pie Overlord
Resident Non-Thieving Pie Overlord
 
Posts: 5704
Joined: Sat Aug 16, 2003 10:06 pm
Location: Commercial Drive, East Van

Re: Performance

Postby Plan 9 » Wed Apr 03, 2013 7:17 pm

Was just glancing at the admin page and noticed some people complaining about lag in chat. Took a screen cap of what perf graph was showing in the attached image
Attachments
sshot-1.png
-Plan 9 aka moss (IT Crowd)
User avatar
Plan 9
Flap, flap, flap....
Flap, flap, flap....
 
Posts: 229
Joined: Tue Feb 10, 2004 1:57 pm
Location: Seattle

Re: Performance

Postby Faust » Wed Apr 03, 2013 10:48 pm

Thanks for the heads up Plan 9. I'm going to restart the server after this round. If the graph looks like that constantly, I'm going to revert those consistency check changes I added a day or so ago.
User avatar
Faust
Fogey
Fogey
 
Posts: 1780
Joined: Thu Jun 03, 2004 11:17 am
Location: BC, Canada


Return to Geriatric Ward NS2 Server

Who is online

Users browsing this forum: No registered users and 2 guests

cron