Major bugs when playing only on OldF server. update: Fixed!

The Life and Times of the Old Fogies NS2 server.

Major bugs when playing only on OldF server. update: Fixed!

Postby mrmoo2002 » Fri Mar 01, 2013 11:30 am

Help!! I've run into some bugs that have made it impossible for me to play on the OldF server. These bugs are only present on the OldF server. Here's my current situation:

- whenever I type anything and press enter, it is not displayed. Mic still works.
- can't evolve into anything as an alien (I can select upgs and higher lifeforms, but when I click evolve nothing happens)
- custom key bindings don't work anymore
- can't do ANYTHING as a comm. For example, I can select cysts by pressing "a" or clicking, but they aren't placed whenever I click.

Again, this is only the case when I'm on the OldF server. All other servers are OK. It's pretty sad for me too as I love playing on this server but can't at all when so much is not working. :( x 2002

I have no idea why it is happening. The problems started all at once after I finished being an alien comm. The game ended, map changed to Descent, and then nothing worked after that. I didn't make any changes to my game files between the maps or anything. I played on OldF last night on the Gorgeous patch and had no problem at all.

Any admins/ppl out there who know, please help!!
User avatar
mrmoo2002
Feeling the Years Pile Up
 
Posts: 23
Joined: Wed Jan 16, 2013 1:52 pm

Re: Major bugs when playing only on OldF server. Help!!

Postby Faust » Fri Mar 01, 2013 11:38 am

This is pretty odd. Someone else complained about this. We might have to disable DAK again.

Edit: DAK is now disabled. Play on GW some more and let me know if any of the issues you mentioned don't present themselves, and which ones still do.

Edit2: Disabling DAK doesn't seem to help, as I now am experiencing the "no text in chat" bug. I'm now getting "authentication failed" when I connect to the server :?

Edit3: A wipe and re-install of NS2 server code has been scheduled for GW at midnight. Sorry of the inconvenience!
User avatar
Faust
Fogey
Fogey
 
Posts: 1780
Joined: Thu Jun 03, 2004 11:17 am
Location: BC, Canada

Re: Major bugs when playing only on OldF server. Help!!

Postby mrmoo2002 » Fri Mar 01, 2013 1:41 pm

Ok, hopefully that'll work. I also had the "Authentication unsuccessful" dialog pop up when I tried to reconnect, so yeah.....*fingers crossed*

Thanks for the help! :like:

Edit: This seems to have fixed it for me. I didn't restart my computer in the interval between this post and the original, so at least that confirms it wasn't an issue with the player files.

Edit 2: a twist!!

I shutdown steam, reconnected, and rejoined the server...everything was working again
Minimized NS2 and opened it again...everything was still working
I pushed one of my bind keys (bound a keys to join marine/random/aliens)....nothing happened (didnt join)
Tried typing a message and hitting enter.....nothing happened!! I broke the game

It seems like it's an issue with key bindings being accepted by the server.
User avatar
mrmoo2002
Feeling the Years Pile Up
 
Posts: 23
Joined: Wed Jan 16, 2013 1:52 pm

Re: Major bugs when playing only on OldF server. Help!!

Postby mtar » Fri Mar 01, 2013 11:40 pm

Yep the server is all sorts of messed up for me. Pretty much the same issues as mrmoo for me. Hopefully things will be fixed in the near future :D.
mtar
Young Insolent Whipper Snapper
 
Posts: 8
Joined: Wed Jan 02, 2013 12:11 am

Re: Major bugs when playing only on OldF server. Help!!

Postby McRiot » Sat Mar 02, 2013 2:02 am

yup, very very broken right now, unplayable. Couldn't evolve, couldn't type, couldn't leave team to join ready room, binds were broken, half the time the loading screen would black the game out on me. Server needs to be re-wired 0.0
McRiot

http://www.razenet.com
Kisst - GuildWars 2 : Stormbluff Isle
McRiot - League of Legends
User avatar
McRiot
King of Lan Partays!
King of Lan Partays!
 
Posts: 1775
Joined: Thu Feb 20, 2003 1:35 am
Location: BC Canada

Re: Major bugs when playing only on OldF server. Help!!

Postby MeowMix » Sat Mar 02, 2013 5:09 am

Just thought I would post up on this, as I was also having these problems yesterday.

I also just joined the server (5am, west coast US) and I'm assuming the server has been restarted as the server name is "NFOservers.com: New server" and I am still unable to type, join teams (via binds) or F4.
MeowMix
Young Insolent Whipper Snapper
 
Posts: 6
Joined: Mon Feb 18, 2013 11:45 pm

Re: Major bugs when playing only on OldF server. Help!!

Postby Faust » Sat Mar 02, 2013 8:43 am

MeowMix wrote:Just thought I would post up on this, as I was also having these problems yesterday.

I also just joined the server (5am, west coast US) and I'm assuming the server has been restarted as the server name is "NFOservers.com: New server" and I am still unable to type, join teams (via binds) or F4.


That's quite unfortunate. I jumped on just now, and I noticed my jointeam binds weren't working. I tried a few others servers, and with the exception of a UWE official server, the other servers didn't accept my jointeam binds either. I'm going to message UWE and my host about this.

Edit: Here's a link to the thread I started in the server ops google group:

https://groups.google.com/forum/?fromgr ... qXws2fd6Bo

Edit2: Thread on NFO forums:

http://www.nfoservers.com/forums/viewto ... f=4&t=8829
User avatar
Faust
Fogey
Fogey
 
Posts: 1780
Joined: Thu Jun 03, 2004 11:17 am
Location: BC, Canada

Re: Major bugs when playing only on OldF server. Help!!

Postby MeowMix » Sat Mar 02, 2013 8:46 am

If you were the "admin" just a second ago that asked if the server is still wonky, I wanted to type yes, but I can't type after pressing any binds.

And as for other server, It's just this one for me. I have been on random Rookie server that work for me, and a couple other vet servers and they are all fine.
MeowMix
Young Insolent Whipper Snapper
 
Posts: 6
Joined: Mon Feb 18, 2013 11:45 pm

Re: Major bugs when playing only on OldF server. Help!!

Postby Faust » Sat Mar 02, 2013 8:54 am

Yeah that was me. Thanks for the feedback.

Edit: So I've tested the issues a bit more on other servers. I noticed that the servers that I can't use console binds on, I also can't chat via text. I just had three other servers do that to me, whereas two others servers worked fine. It seems these issues have a relationship with each other. Someone else (Communistwithagun) suggested that the server might not be syncing with the client properly?
User avatar
Faust
Fogey
Fogey
 
Posts: 1780
Joined: Thu Jun 03, 2004 11:17 am
Location: BC, Canada

Re: Major bugs when playing only on OldF server. Help!!

Postby MeowMix » Sat Mar 02, 2013 9:03 am

Trying to trouble shoot it from my end. One thing i'm noticing is only when i join OldF so Far, watching the console at precaching the game has 2 errors in the console ( Error: Couldn't open file " ), trying to see if something in the cache on my end.

Edit: A full delete of the Cache and Workshop and still no luck

EDIT 2: It looks like we aren't alone in this as it is on the NS2 Tech Support forums in various descriptions.

http://forums.unknownworlds.com/discuss ... not-f4-ect
http://forums.unknownworlds.com/discuss ... line-games

are 2 I found right off the bat, the second one says switching to just full screen fixes it ( I was in Full-window ) I tried it with no luck.
MeowMix
Young Insolent Whipper Snapper
 
Posts: 6
Joined: Mon Feb 18, 2013 11:45 pm

Re: Major bugs when playing only on OldF server. Help!!

Postby mik3y » Sat Mar 02, 2013 10:32 am

I was having the same issues yesterday, but it seems to be working fine for me today

*edit* nevermind. I was able to chat when I joined the game and was in the ready room, but once I joined a team I was no longer able to chat. I was able to transform into higher lifeforms though
mik3y, aka Zigga
mik3y
Fogey
Fogey
 
Posts: 181
Joined: Mon Nov 28, 2005 6:19 pm
Location: Langley BC

Re: Major bugs when playing only on OldF server. Help!!

Postby mtar » Sat Mar 02, 2013 2:45 pm

I don't know if this will help, but here is what will trigger the bugged state (unable to text chat, buy, evolve, use any of the x menu, request medpacks/ammo, black screen after mapchange) for me:

Opening Console
Shift Tabbing into Steam Overlay


Even avoiding these two actions will eventually lead to the bugged state, so I must be overlooking something. I'll edit this post should I encounter anything else.
mtar
Young Insolent Whipper Snapper
 
Posts: 8
Joined: Wed Jan 02, 2013 12:11 am

Re: Major bugs when playing only on OldF server. Help!!

Postby Faust » Sat Mar 02, 2013 10:41 pm

The playtesting lead (Ironhorse) has posted instructions in one of the threads meow-mix linked in order to help UWE squash these bugs. If we want to help UWE fix these issues ASAP, we need to follow through on Ironhorse's requests. Here's the thread in question:

http://forums.unknownworlds.com/discuss ... not-f4-ect

I'm going to start working on this now.

Edit: I've done a lot of testing and I've figured out a couple key details about these bugs. For starters, they all seem related to each other. Once you get in a "bugged" state, you will start encountering all the issues people mentioned in this thread. For the second detail, I'll quote myself from the thread I linked above:

So, I think I've narrowed down what initiates these series of bugs, as they all seem related. When on the 4 servers I listed, it comes down to using binds that directly place the player on marines or aliens from ready room, or a bind that places the player back into the readyroom from a team (or by clicking ready room in the menu when on a team). Once I did this, I got "bugged out" and could not type via text, evolve lifeforms, pick up weapons as marines or buy stuff from the armory or prototype lab. Additionally I couldn't log out of the hive when in a "bugged" state.

In order to avoid this bugged state, DO NOT JOIN TEAMS/READYROOM DIRECTLY OR CLICK READYROOM BUTTON IN MENU WHEN ON A TEAM.

Ironhorse, I deleted the options.xml file you mentioned and retested. The only change I noticed is on a couple of the bug-inducing servers, I would get in a bugged state soon after joining, without using binds to go directly to a team. However, when on the OldF server, I would not get in a bugged state until I tried to directly go to the ready room or a team.
User avatar
Faust
Fogey
Fogey
 
Posts: 1780
Joined: Thu Jun 03, 2004 11:17 am
Location: BC, Canada

Re: Major bugs when playing only on OldF server. Help!!

Postby Furious Gorge » Sun Mar 03, 2013 3:36 am

Look at my post in the same thread:

In short, I experienced the issue, even when I did not use any binds, but rather, simply walked into the team portal/door to join a team.
[OldF]*Furious Gorge aka 9, 1001, NSPlayer, CAPS LOCK, CLARK KENT
User avatar
Furious Gorge
OldF sekrat polizei
OldF sekrat polizei
 
Posts: 1161
Joined: Tue Feb 11, 2003 5:15 am
Location: Vancouver, Canada

Re: Major bugs when playing only on OldF server. Help!!

Postby Faust » Sun Mar 03, 2013 10:33 am

Are you sure you didn't enter 3 characters or less in chat? As I mentioned in the UWE thread, I found this as a new criteria for getting bugged. Time doesn't seem to be an issue for me to get in a bugged state, it comes down to trying to join a team/ready room directly or entering three characters or less in chat.
User avatar
Faust
Fogey
Fogey
 
Posts: 1780
Joined: Thu Jun 03, 2004 11:17 am
Location: BC, Canada

Next

Return to Geriatric Ward NS2 Server

Who is online

Users browsing this forum: No registered users and 2 guests

cron